December 29, 2018

I have an older iMac in my kitchen with a keyboard that’s on its last legs. Some of the keys don’t even work anymore, and it’s an exercise in frustration to use. This evening I tried to plug in an older aluminum keyboard, and it didn’t work. The caps lock key wouldn’t even light up.

You’ll never believe the fix for this keyboard!

(See? You too can write clickbait headlines!)

The Problem

One thing I received for Christmas was a new wireless Apple keyboard. It was intended for the kitchen iMac, since that keyboard was on its last legs. The machine is an early 2009 20" model that I put an SSD in a while back so it could limp along for just a bit longer.

I liked the new keyboard so much that I decided to use it on my main workstation, so I moved the wired keyboard (model A1243) from that one to the kitchen for the time being. Unfortunately, it didn’t work. The caps-lock key wouldn’t even light up.

There were some odd log entries about failing to clear change bits, but that was all. The thing just plain didn’t work, which was a shock. It’s not exactly a brand new keyboard, so it should be perfectly compatible.

This is apparently not a new problem; I found the answer after googling around for a while.

The Solution

Get a load of this: the solution? Grab one of those Apple USB extension cables that they used to ship with their keyboards, and plug the keyboard into it. Then plug that cable into the computer. Instant working keyboard.

Yes, you read that right: adding an extension to the USB cable solved the problem perfectly.

The only thing I can figure is that something is slightly out of spec in either the keyboard or the USB port, and the additional resistance or capacitance of the extension cable is bringing it back into spec. That’s just a guess – I really don’t know – but it’s all I’ve got.

Odd, but I have a working keyboard in the kitchen now, at least until I get around to blowing another hundred bucks on another wireless keyboard. Maybe that’ll be back on my Christmas list next year…